Иногда нам необходимо отобразить дату в MS Excel несколько иначе чем позволяют заданные форматы. Для этого существует минимум два способа.

Первый способ:

Можно воспользоваться формулой "ТЕКСТ". Как это работает? Введите в ячейку "A1" любую дату, а в соседнюю ячейку введите формулу =ТЕКСТ(A1;"ДД ММММ ГГГГ ДДДД"):

Как красиво написать дату?

Как вы видите в ячейке "B1" мы получили дату, написанную как текст и добавленный к ней день недели.

Что означают сочетание букв в формате?

МОтображение месяца в виде числа без начального нуля (1-12)
ММОтображение месяца в виде числа с начальным нулем, если он необходим (01-12)
МММОтображение сокращенного названия месяца (Янв – Дек)
ММММОтображение полного названия месяца (Январь – Декабрь)
МММММОтображение месяца в виде одной буквы (Я–Д)
ДОтображение дня в виде числа без начального нуля (1-31)
ДДОтображение дня в виде числа с начальным нулем, если он необходим (01-31)
ДДДОтображение сокращенного названия дня недели (пн – вс)
ДДДДОтображение полного названия дня недели (понедельник – воскресенье)
ГГОтображение года в виде двузначного числа (00-14)
ГГГГОтображение года в виде четырехзначного числа (2000-2014)

Попробуйте разные сочетания и разную последовательность - посмотрите, как меняется результат.

Второй способ:

Можно задать свой формат даты. Более подробно в статье (Как создать свой формат данных?).

Выделите ячейку, которая содержит дату, откройте диалоговое окно "Формат Ячеек", задайте следующий формат ДД ММММ ГГГГ ДДДД и нажмите "ОК":

kak-krasivo-napisat-datu_2.png

В результате получиться следующее:

kak-krasivo-napisat-datu_3.png

В чем разница между этими двумя способами? В первом случае вы получаете дату в текстовом формате, а это значит, что ее нельзя будет использовать в расчетах. Во втором случае дата остается датой - меняется лишь внешний вид.

Комментарии  

# Таня 21.11.2016 12:14
Большое спасибо))) помогло))) У вас супер сайт!
Ответить | Ответить с цитатой | Цитировать
# Хвостов Сергей 11.02.2016 14:52
1. Проверьте дату.
2. Формат пишите большими буквами ММММ.
Ответить | Ответить с цитатой | Цитировать
# Вячеслав13 11.02.2016 13:53
exel 10....вместо месяца выдает 00...?
Ответить | Ответить с цитатой | Цитировать
# Таня 21.11.2016 11:55
у меня тоже exel 10 вместо месяца выдает 00, почему-то
Ответить | Ответить с цитатой | Цитировать
# Хвостов Сергей 21.11.2016 12:11
Формат пишите "большими" буквами. Это важно! Попробуйте поменять шрифт на английский.
Ответить | Ответить с цитатой | Цитировать

Добавить комментарий

Защитный код
Обновить